System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Possible SMS Delivery Delay
Incident Report for Telesign system status
Resolved
This incident has been resolved.
Posted Mar 31, 2020 - 03:17 PDT
Investigating
Date: 03/31/20
Start Time: [01:04 AM PDT]
End Time: [03:07 AM PDT]

TeleSign performed emergency maintenance in one of TeleSign's data centers during the above-mentioned time frame. Although connectivity issues and service degradation are not expected, this is a proactive notice to inform you in case of intermittent service delays during this period.

We apologize in advance for any inconvenience and appreciate your patience during this maintenance window.

If you have any questions, please contact us at support@telesign.com.
Posted Mar 31, 2020 - 03:02 PDT
This incident affected: Enterprise Services (SMS & SMS Verify) and Standard Services (SMS).