System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Possible Delays
Incident Report for Telesign system status
Resolved
We were experiencing instability on our platform which could have caused some delays in delivery.

Date: 05/25/23
Start Time: 07:25 AM PDT
End Time: 07:43 AM PDT

Our Network Engineers have identified and successfully resolved this incident. We sincerely apologize for the inconvenience this may have caused you.
Posted May 25, 2023 - 10:45 PDT
Investigating
Dear Customers and Partners,

We were experiencing instability on our platform which could have caused some delays in delivery.

Date: 05/25/23
Start Time: 07:25 AM PDT
End Time: 07:43 AM PDT

Our Network Engineers have identified and successfully resolved this incident. We sincerely apologize for the inconvenience this may have caused you.

If you have any questions, please contact us at support@telesign.com.
Posted May 25, 2023 - 10:44 PDT
This incident affected: Operator Alerts (Operator Alerts WW).