System Status

This page offers API uptime information for TeleSign services, in addition to incident history reports and service issues alerts.
Tanzania Operator Service Alert - Tanzania MIC Tanzania Ltd (Tigo) 640/02
Incident Report for TeleSign System Status
Resolved
We received notification that the network issues previously reported by MIC Tanzania Ltd (Tigo) 640/02 from Tanzania have been resolved.MIC Tanzania Ltd (Tigo) 640/02 end users should no longer experience delays receiving SMS messages as all services are back to functioning properly.

On behalf of the Operator, we apologize for any inconvenience this issue may have caused. If you have additional questions, please feel free to contact support@telesign.com.
Posted 17 days ago. Oct 04, 2018 - 00:27 PDT
Update
We are continuing to work on a fix for this issue.
Posted 17 days ago. Oct 04, 2018 - 00:25 PDT
Identified
We received notification that Tanzania MIC Tanzania Ltd (Tigo) from Tanzania is currently experiencing network issues, and this may cause a delay in the delivery of SMS messages. We will inform you once the operator has come to a resolution.
Posted 17 days ago. Oct 03, 2018 - 14:28 PDT
This incident affected: Operator Alerts.