System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Generic senders forbidden for operator Ethiopian Telecommunications
Incident Report for Telesign system status
Resolved
This incident has been resolved.
Posted Oct 13, 2022 - 01:43 PDT
Identified
Country: Ethiopia

Operator: Ethiopian Telecommunications (636/01)

Effective Date: 5th of January

Details: Generic senders will no longer be allowed for Ethiopian operator Ethiopian Telecommunications (636/01), operator announced that they will be blocked from the 5th of January.
Posted Jan 04, 2022 - 06:36 PST
This incident affected: Regulatory Updates.