System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

SMS Delivery Delay - non-US
Incident Report for Telesign system status
Resolved
Dear Customers and Partners,

SMS delivery has now been restored as of 19.50 PDT/PST.

We are currently reviewing root cause and will provide additional information once we have completed the investigation.
Posted Jun 17, 2020 - 21:50 PDT
Update
We are continuing to investigate this issue.
Posted Jun 17, 2020 - 20:12 PDT
Investigating
Dear Customers and Partners,

Our internal monitoring system shows possible intermittent SMS delivery delays on non-US traffic starting at 19.00 PDT/PST

Our Network Operations Team is currently investigating and working on a speedy resolution.

We will inform you once the issue has been remedied.
Posted Jun 17, 2020 - 20:11 PDT
This incident affected: Enterprise Services (SMS & SMS Verify) and Standard Services (SMS).