System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Possible Delays in Processing Times for PhoneID
Incident Report for Telesign system status
Resolved
Dear Customers and Partners,

Our Network Engineers have identified and successfully resolved this incident. All services are back to functioning properly.

We sincerely apologize for the inconvenience this may have caused you.

If you have any questions, please contact us at support@telesign.com.
Posted May 20, 2023 - 00:57 PDT
Investigating
Dear Customers and Partners,

We are experiencing instability on our platform, which could cause increased processing time for PhoneID.

Our team is investigating the issue and will keep you updated as soon as we have preliminary findings.

If you have any questions, please get in touch with us at support@telesign.com.
Posted May 19, 2023 - 21:42 PDT
This incident affected: Enterprise Services (PhoneID Standard) and Standard Services (PhoneID).