System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

PhoneID Product - Degraded Performances - the US&CA fixed line numbers
Incident Report for Telesign system status
Resolved
Dear Customers and Partners,

We would like to let you know that starting 06:50 AM PDT all services have been restored.

If you have any questions, please contact us at support@telesign.com.
Posted Feb 04, 2020 - 07:59 PST
Update
Dear Customers and Partners,

Our Network Operations team identified that one of TeleSign's partners used for Phone ID services is experiencing networking issues at the moment.

So far, this affects our Phone ID transactions related to the US fixed lines.

We will inform you once the issue has been remedied.
Posted Feb 04, 2020 - 07:25 PST
Identified
Dear Customers and Partners,

Our internal monitoring system shows intermittent delivery delays related to TeleSign's Phone ID product starting at 5:45 AM PDT.

Our Network Operations team is currently investigating and working on a speedy resolution.

We will inform you once the issue has been remedied.
Posted Feb 04, 2020 - 07:12 PST
This incident affected: Enterprise Services (PhoneID Contact, PhoneID Live) and Standard Services (PhoneID).