System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

SMS Delivery Delay - Multiple destinations
Incident Report for Telesign system status
Resolved
Dear Customers and Partners,

SMS delivery has now been restored as of 02:56 PDT/PST.

We are currently reviewing the root cause and will provide additional information once we have completed the investigation.
Posted May 16, 2020 - 03:30 PDT
Update
We are continuing to monitor for any further issues.
Posted May 16, 2020 - 01:52 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 16, 2020 - 01:39 PDT
Update
We are continuing to investigate this issue.
Posted May 16, 2020 - 01:06 PDT
Investigating
Dear Customers and Partners,

Our internal monitoring system shows intermittent SMS delivery delays on ALL non-US traffic (Canada not affected) starting at 00:23 AM PDT/PST.

Our Network Operations team is currently investigating and working on a speedy resolution.

We will inform you once the issue has been remedied.
Posted May 16, 2020 - 01:00 PDT
This incident affected: Enterprise Services (SMS & SMS Verify) and Standard Services (SMS).