System Status

This page offers API uptime information for TeleSign services, in addition to incident history reports and service issues alerts.
SMS Delivery Reports Delay for non-US traffic - Resolved
Incident Report for TeleSign System Status
Resolved
This incident has been resolved.
Posted 20 days ago. Aug 29, 2019 - 06:24 PDT
Investigating
Dear Customers and Partners,

Our internal monitoring system registered possible SMS DLR delays for a portion of non-US SMS messaging traffic, starting at 05:00 AM PDT.

SMS traffic is not affected, only delivery reports were delayed in the mentioned period.

This is resolved at 05:25 AM PDT.

Our Network Operations team continues to monitor the delivery channels and is investigating the cause. We will provide more details as they are available.
Posted 21 days ago. Aug 28, 2019 - 05:59 PDT
This incident affected: Enterprise Services (SMS Verify) and Standard Services (SMS).