System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Operator Service Alert Iran (IR) - MCI/TCI (432/11)
Incident Report for Telesign system status
Resolved
Date: 06/17/21
Start Time: 12:49 AM PDT
End Time: 02:32 PM PDT

We received notification that the network issues previously reported by MCI/TCI from Iran have been resolved. MCI/TCI end users should no longer experience delays receiving SMS messages as all services are back to functioning properly.

On behalf of the Operator, we apologize for any inconvenience this issue may have caused. If you have additional questions, please feel free to contact support@telesign.com.
Posted Jun 17, 2021 - 16:34 PDT
Update
Dear Customers and Partners,

We have received an info about upcoming elections planned in Iran (June 18th Iranian time).

We have just been advised that all A2P/P2P connectivity shall be temporarily suspended to MCI Iran effective.

Affected time period:
Start-time: 06/17/21 12:49AM PDT
Expected end-time: 06/19/21 10:00 AM PDT

As a result of the above, service has already been suspended.
Posted Jun 17, 2021 - 06:13 PDT
Identified
Date: 06/17/21
Start Time: 12:49AM PDT
End Time: Ongoing

We received notification that MCI/TCI from Iran is currently experiencing network issues, and this may cause a delay in the delivery of SMS messages. We will inform you once the operator has come to a resolution.
Posted Jun 17, 2021 - 00:56 PDT
This incident affected: Operator Alerts (Operator Alerts WW).