System Status

This page offers API uptime information for TeleSign services, in addition to incident history reports and service issues alerts.
Operator Service Alert Bangladesh - TeleTalk 470/04
Incident Report for TeleSign System Status
Resolved
We received notification that the network issues previously reported by TeleTalk from Bangladesh have been resolved. TeleTalk end users should no longer experience delays receiving SMS messages as all services are back to functioning properly.

On behalf of the Operator, we apologize for any inconvenience this issue may have caused. If you have additional questions, please feel free to contact support@telesign.com.
Posted 16 days ago. Jan 02, 2019 - 04:32 PST
Identified
We received notification that TeleTalk from Bangladesh is currently experiencing network issues, and this may cause a delay in the delivery of SMS messages. We will inform you once the operator has come to a resolution.
Posted 17 days ago. Jan 01, 2019 - 16:27 PST
This incident affected: Operator Alerts.