System Status

This page offers API uptime information for TeleSign services, in addition to incident history reports and service issues alerts.
Operator Service Alert Bhutan - B-Mobile (402/11)
Incident Report for TeleSign System Status
Resolved
We received notification that the network issues previously reported by B-Mobile from Bhutan have been resolved. B-Mobile end users should no longer experience delays receiving SMS messages as all services are back to functioning properly.

On behalf of the Operator, we apologize for any inconvenience this issue may have caused. If you have additional questions, please feel free to contact support@telesign.com.
Posted 19 days ago. Nov 29, 2018 - 23:12 PST
Identified
We received notification that B-Mobile from Bhutan is currently experiencing network issues, and this may cause a delay in the delivery of SMS messages. We will inform you once the operator has come to a resolution.
Posted 20 days ago. Nov 29, 2018 - 19:58 PST
This incident affected: Operator Alerts.