System Status

This page offers API uptime information for TeleSign services, in addition to incident history reports and service issues alerts.
Operator Service Alert Nigeria - Nigeria Communications Ltd (MTN) (621/30)
Incident Report for TeleSign System Status
Resolved
This incident has been resolved.
Posted 13 days ago. Dec 06, 2018 - 11:37 PST
Identified
We received notification that Nigeria Communications from Nigeria is currently experiencing network issues, and this may cause a delay in the delivery of SMS messages. We will inform you once the operator has come to a resolution.
Posted 13 days ago. Dec 06, 2018 - 08:20 PST
This incident affected: Operator Alerts.