System Status

This page offers API uptime information for TeleSign services, in addition to incident history reports and service issues alerts.
Operator Quality Degradation Alert Ethiopia - Ethiopian Telecommunications 636/01
Incident Report for TeleSign System Status
Resolved
Date:16/05/20
Start Time:15/05/20 09:09 AM PDT
End Time: 16/05/20 18:00 PM PDT

We received notification that the network issues previously reported by Ethiopian Telecommunicationsfrom Ethiopia have been resolved. Ethiopian Telecommunications end users should no longer experience delays receiving SMS messages as all services are back to functioning properly.

On behalf of the Operator, we apologize for any inconvenience this issue may have caused. If you have additional questions, please feel free to contact support@telesign.com.
Posted May 16, 2020 - 18:29 PDT
Identified
Date: 15/05/2020
Start Time: 09:09 AM PDT
End Time: Ongoing

We received notification that Ethiopian Telecommunications from Ethiopia is currently experiencing network issues, and this may cause quality degradation. We will inform you once the operator has come to a resolution.
Posted May 15, 2020 - 07:15 PDT
This incident affected: Operator Alerts.