System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Czech Republic Sender ID Registration fees
Incident Report for Telesign system status
Resolved
This incident has been resolved.
Posted Oct 13, 2022 - 02:10 PDT
Identified
Country: Czech Republic

Operators: T-Mobile and O2 (Telefonica)

Effective Date: Already started

Details: The Sender ID registration fees for the Czech Republic operators:

- operator T-Mobile has a monthly fee of $5;
- operator O2 (Telefonica) has a one-time fee of $9;
Posted Nov 29, 2021 - 05:29 PST
This incident affected: Regulatory Updates.