System Status

This page offers API uptime information for TeleSign services, in addition to incident history reports and service issues alerts.
Operator Service Alert Iran - MCI/TCI 432/11
Incident Report for TeleSign System Status
Resolved
Date:12/05/2020
Start Time: 02:08 AM PDT
End Time: 06:30 AM PDT

We received notification that the network issues previously reported by MCI/TCI from Iran have been resolved. MCI/TCI end users should no longer experience delays receiving SMS messages as all services are back to functioning properly.

On behalf of the Operator, we apologize for any inconvenience this issue may have caused. If you have additional questions, please feel free to contact support@telesign.com.
Posted May 12, 2020 - 06:46 PDT
Identified
Date: 12/05/2020
Start Time: 02:08 AM PDT/PST
End Time: Ongoing

We received notification that MCI/TCI from Iran is currently experiencing network issues, and this may cause a delay in the delivery of SMS messages. We will inform you once the operator has come to a resolution.
Posted May 12, 2020 - 02:48 PDT
This incident affected: Operator Alerts.