System Status


This page offers API uptime information for TeleSign services, in addition to incident history reports and service issues alerts.
Operator Service Alert Trinidad and Tobago - TSTT 374/12
Incident Report for TeleSign System Status
Resolved
Start Time: 11/19/2021 04:19 PST
End Time: 11/19/2021 07:03 PST

We received notification that the network issues previously reported by TSTT from Trinidad and Tobago have been resolved. TSTT end users should no longer experience delays receiving SMS messages as all services are back to functioning properly.

On behalf of the Operator, we apologize for any inconvenience this issue may have caused. If you have additional questions, please feel free to contact support@telesign.com.
Posted Nov 19, 2021 - 20:29 PST
Identified
Date: 11/18/2021
Start Time: 04:19 PST
End Time: Ongoing

We received notification that TSTT from Trinidad and Tobago is currently experiencing network issues, and this may cause a delay in the delivery of SMS messages. We will inform you once the operator has come to a resolution.
Posted Nov 18, 2021 - 16:28 PST
This incident affected: Operator Alerts.