System Status

This page offers API uptime information for TeleSign services, in addition to incident history reports and service issues alerts.
Voice Traffic degradation toward US Operators
Incident Report for TeleSign System Status
Resolved
The issue is resolved with changes made on Friday, however we continue to monitor and are working with partners to prevent the issue reoccurring.
Posted 10 days ago. Feb 10, 2019 - 04:02 PST
Monitoring
TeleSign teams have made some changes to improve Voice message delivery for US markets. We see marked improvement for the majority of traffic and are working on further improvements. The issue is being closely monitored.
Posted 12 days ago. Feb 08, 2019 - 04:58 PST
Identified
Dear Customers,

TeleSign is currently investigating a reported Voice traffic degradation toward all US Operators. We are informed that some of our Voice transactions are not reaching end users, which prevents verification.
Our team is working with US Operators in order to solve this, and we will inform here as we have more information.
Posted 12 days ago. Feb 08, 2019 - 00:18 PST
This incident affected: Enterprise Services (Voice Verify) and Standard Services (Voice).