System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

T-Mobile 10DLC Update
Incident Report for Telesign system status
Resolved
This incident has been resolved.
Posted Oct 13, 2022 - 01:43 PDT
Identified
Effective March 1st, 2022, T-Mobile will be ending the grace period for 10DLC campaign activation fees. On or after March 1st, a $50 campaign fee will be charged for each 10DLC campaign that is activated or migrated.

In addition, T-Mobile will increase the per-message fees for any messaging traffic delivered by way of unsanctioned P2P/inter carrier routes.

The current SMS price is $0.003, effective 1st of March it will be $0.004; current MMS price is $0.01, effective 1st of March it will be $0.013.
Posted Jan 14, 2022 - 07:38 PST
This incident affected: Regulatory Updates.