System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Delivery Delay
Incident Report for Telesign system status
Postmortem

Below you will find the Root Cause Analysis for the incident that occurred on Tuesday, October 15th, 2019.

Original Reported Subject: Delivery Delay

Date: Tuesday, October 15th, 2019

Start Time: 2:01AM PDT

End Time: 2:14 AM PDT

Summary:

On Tuesday, October 15th TeleSign’s internal monitoring detected delayed delivery for all SMS traffic starting at 2:01 AM PDT. TeleSign’s SMS Verify and SMS API were available throughout this reported incident, however SMS processing time was delayed.

Root Cause Analysis:

A load balancer failover at 2:01 AM PDT in one data center caused multiple virtual IPs hosted on the load balancer to become unavailable. SMS transactions then started to queue until the load balancer stabilized at 2:12 AM PDT. At 2:14 AM PDT TeleSign’s network team confirmed all queues were cleared and no further delays were observed.

Preventive Measures:

To minimize the risk of, and/or prevent this issue from recurring in the future, TeleSign’s Tech OPS team has taken the following actions:

· Vendor confirmed presence of bug and worked with Telesign on recommended workaround

· Additionally, a configuration audit regarding failovers in TeleSign’s data centers was also performed.

We apologize for the inconvenience this may have caused you. Should you have any questions, please don’t hesitate to contact us at support@telesign.com.

Posted Oct 21, 2019 - 18:08 PDT

Resolved
Dear Customers and Partners,

Previously reported delivery delay has now been restored as of 2:10 AM PDT.

We are currently reviewing root cause and will provide additional information once we have completed the investigation.
Posted Oct 15, 2019 - 02:19 PDT
Investigating
Dear Customers and Partners,

Our internal monitoring system shows intermittent delivery delays on ALL traffic starting at 2 AM PDT

Our Network Operations team is currently investigating and working on a speedy resolution.

We will inform you once the issue has been remedied.
Posted Oct 15, 2019 - 02:15 PDT
This incident affected: Enterprise Services (SMS & SMS Verify) and Standard Services (SMS).