System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

NOC is mandatory for every Sender ID registration in UAE and consent is needed.
Incident Report for Telesign system status
Resolved
This incident has been resolved.
Posted Oct 13, 2022 - 02:19 PDT
Identified
Country: United Arab Emirates

Operator: all

Effective Date: Already started

Details: The new upcoming change in the UAE market is that NOC is obligatory for every Sender ID registration and consent is needed. The operator Etisalat (424/02) is launching a new service CMS (Consent Management Service) in order to control the unsolicited marketing communication in the UAE market. This essentially means that everyone will need to give consent to receive the SMS.
Posted May 07, 2021 - 04:16 PDT
This incident affected: Regulatory Updates.