System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Possible Delays
Incident Report for Telesign system status
Resolved
Dear Customers and Partners,

Our Network Engineers have identified and successfully resolved this incident. We sincerely apologize for the inconvenience this may have caused you.

Date: 03/19/23
Start Time: 15:13 PM PDT
End Time: 15:17 PM PDT

If you have any questions, please contact us at support@telesign.com.
Posted Mar 19, 2023 - 15:33 PDT
Investigating
Dear Customers and Partners,

We are experiencing instability on our platform which could cause some delays in delivery.

Our team is investigating the issue and we will make sure to keep you updated as soon as we have preliminary findings.

If you have any questions, please contact us at support@telesign.com.
Posted Mar 19, 2023 - 15:24 PDT
This incident affected: Enterprise Services (SMS & SMS Verify, Voice Verify, Smart Verify, Push Verify, PhoneID Standard, PhoneID Contact, PhoneID Live, Score) and Standard Services (SMS, Voice, PhoneID, Score, App Verify).