System Status


This page offers API uptime information for Telesign services, in addition to incident history reports and service issues alerts.

Service Metrics

Ethiopia Operator Service Alert – Ethiopian Telecommunications 636/01
Incident Report for Telesign system status
Resolved
We received notification that the network issues previously reported by Ethiopian Telecommunications 636/01 from Ethiopia have been resolved. Ethiopian Telecommunications end users should no longer experience delays receiving SMS messages as all services are back to functioning properly.

On behalf of the Operator, we apologize for any inconvenience this issue may have caused. If you have additional questions, please feel free to contact support@telesign.com.
Posted Jun 25, 2017 - 14:38 PDT
Identified
We received notification that Ethiopian Telecommunications from Ethiopia is currently experiencing network issues, and this may cause a delay in the delivery of SMS messages. We will inform you once the operator has come to a resolution.
Posted Jun 24, 2017 - 22:14 PDT
This incident affected: Standard Services (SMS, Voice).